1) Please check that the application is compatible with your version of MacOS. 


Currently our products are supported by Mac OS X® 10.7 or higher.


2) If you have earlier version of Movavi applications and MacOS version Mac OS X 10.10 (Yosemite), they might be incompatible.


We would suggest either using the applications like Movavi Video Converter 4 and Movavi Split Movie on earlier versions of MacOS, or use one of our special upgrade discounts to upgrade to later versions.

3) Try reinstalling the application using this instruction